TECH DOC

Категории

Основы [2]
Cisco [19]
MPLS [1]

Map

Теги

Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Поделиться

Каталог статей

Главная » Статьи » Lan » Cisco

Настройка Cisco 1700 с картой Ethernet WIC как клиент PPPoE с NAT
Данный документ показывает как настроить Cisco 1700 используя Интерфейсную карту Ethernet WAN (WIC-1ENET) для работы в качестве клиента PPPoE с сетевой трансляцией адресов NAT.
Для того, чтобы работать с PPPoE у вас должен быть установлен IOS с поддержкой ADSL PLUS функциональностью. Функциональность ADSL-only не поддерживает PPPoE на Cisco 1700
 
Несколько компьютеров могут быть установлены за Cisco 1700 маршрутизатором и их трафик посылается по PPPoE сессии, он может быть зашифрован, отфильтрован, и над ним может быть выполнен NAT

Карта WIC-1ENET обладает следующими ограничениями:
 
  • WIC-1ENET не поддерживается на платформах отличных от Cisco 1700
  • Поддерживается только витая пара RJ45
  • Нет автосогласования между полудуплексым и полнодуплексными режимами передачи
  • WIC-1ENET не может использоваться для загрузки файлов по TFTP когда роутер находится в режиме ROMMON
  • WIC-1ENET не опознается роутером в режиме ROMMON
  • Текущие Cisco IOS поддерживают WIC-1ENET только в слоте 0 маршрутизатора Cisco 1700

Сетевая диаграмма показана на рисунке:
 

 
 
Здесь на маршрутизаторе Cisco 1700 настраивается клиент PPPoE с помощью команд VPDN. В качестве примера ISP выбран универсальный концентратор доступа Cisco 6400

Конфигурация Cisco 1700
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin

!--- PPPoE клиент запрашиват установление соединение с устройством агрегации(6400 NRP)

protocol pppoe
!
int Dialer1
ip address negotiated
encapsulation ppp
ip mtu 1492

!--- Ethernet MTU = 1500 по умолчанию
!--- Выставляем 1492 + PPPoE заголовок = 1500

ip nat outside
dialer pool 1

!--- Завязываем на Ethernet0.

dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
!

!--- The ISP говорит вам тип используемой аутентификации
ppp pap sent-username password

!
dialer-list 1 protocol ip permit
!

!--- Это внутренняя Ethernet сеть.
interface FastEthernet0
ip address 10.0.0.1 255.255.255.0
ip nat inside
!
interface Ethernet0
pppoe enable
pppoe-client dial-pool-number 1


!--- Код PPPoE клиента завязан на dialer интерфейс с которого клонируется интерфейс virtual-access.
!

!--- Для NAT указываем интерфейс Dialer1 и добоавляем маршрут по умолчанию
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit

!--- Для целей NAT.
access-list 1 permit 10.0.0.0 0.0.0.255

 
 


Источник: http://www.ciscolab.ru
Категория: Cisco | Добавил: Kogr (05.01.2010) | Автор: HunSolo W
Просмотров: 2823 | Рейтинг: 0.9/20

Поиск

Vir Actiy

IP

Узнай свой IP адрес

Scan File

Scan URL

+

Бесплатный анализ сайта

Статьи , новости информационных технологий , обзоры , описание ошибок , Операционные системы , системные ошибки , новые технологии , аутсорсинг , windows , Linux , VoIP , FreeBSD , Cisco , информационная безопасность , Win7 , Win8 , server , проблемы с серверами , ИТ , управление инфраструктурой и многое другое…